Players   Parents   Libraries

FCMinecraft works with 1.8!

A lot of you have been asking when the server will work with 1.8 clients. The answer is now (With a few caveats)!

The server software we are using (Spigot) has updated its conneciton protocol to allow for 1.8 clients, however, they still have not updated the server to the point where the 1.8 features are available. This takes some time and I'm sure they will eventually get around to it. In the meantime, you will no longer have to roll back your Minecraft version in the launcher in order to connect to the server.

Unfortunately, Craftbukkit and Spigot have run in to a little bit of a legal snag when they recieved a DMCA takedown notice from one of the developers which will affect our ability to do any upgrades until it is worked out.

We will, of course, do our best to work around these problems. Dig on!


Maintained by Darien Library